25+5 clock works but I'm not passing the tests

I’m not passing the tests that test the timer and updating the break and session lengths.
I’ve tried 4 different versions. I believe I’m meeting all the criteria and it all works but I’m not passing tests. The assertion errors are cryptic and I can’t make any sense of them.

I’ve got a clock here https://codepen.io/Mientje/pen/LYRPvqW?editors=0010 and a first clock here https://codepen.io/Mientje/pen/RwRJMPK

Please help,

I have exactly the same problems right now, my app appears to be working perfectly when I go through the tests manually, but the tests themselves are failing.

Did you manage to make any progress with this?


I fixed it but not because of one illuminating insight. First I made the clock all over again just using jQuery, that was simpler and I passed all tests. Then I turned that jQuery into React and I got out of the slump.
One thing I can tell you is that the success of some assertions depend on others, not passing one test may lead to failure in another. I’d be staring at some test but the problem lay somewhere else, I wish to God I’d remember but it’s too long ago.
If you send a link I can look and compare and maybe give you a useful hint.


I managed to resolve almost all of my issues, I was using Fontawesome icons which I clickable on their own so I didn’t wrap them in <button> tags. It worked fine like this when I clicked them manually, but I had to wrap them in <button> tags to get them working with the test scripts.

Great! Glad to have been of no real help.
Anytime, greets,

I appreciate you taking the time to read my post and have a think about the issue, all help is good help.


1 Like