414 Request-URI Too Large nginx

Hi .I don’t know if anyone can help but I get this error 414 Request-URI Too Large
nginx when trying to update my site.I have asked my my isp but they just say the file is to large.Any help would be great.
Thank you in advance.

I doubt it has anything to do with file size.

This MDN article gives a few possibilities

I don’t think we can provide much help considering we have little to no information to go on. The site was updated how?

Thank you Lasjorg but all I know is that I cannot do anything on my site
I tried to change a setting in my theme and the error came up .

I asked my isp I you cannot get into the Nginx server settings.
But they will not do it so I was just wondering if there was anoter way round it.
Thanks anyway.
Roger

Is it a WordPress site, or what?

What setting did you change? Have you looked at the theme support (FAQ, forum, changelogs)?

Can you change it back or are you locked out of the admin area because of the change? If so ask the hosting provider to roll you back (you may or may not lose a little data doing a rollback).

Again, we are not really in a good position to provide you with the help you need. The hosting provider is your best bet even though for most cheap hosting with WordPress or other site builders they aren’t really economically incentivized to give good help so the support is often very lacking. See if you can get help or ask that they escalate your support ticket.

Yes it is a word press site I tried setting it to an earlier back-up but it must have happened before and I didn’t notice.

I will try the forum for the theme to see if anyone has had the same issue. But I won’t hold my breath.

I have a unlimited hosting account with Crazy Domains but they don’t seem to want to help.

I don’t really won’t to loose at the seo links that go to the site but looks like I might have to

rebuild it.

Thanks again for your time

Roger

Hi lasjorg

I just did a test on the website with a php checker And got this error message

Error: SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

Response:

I think this error 414 Request-URI Too Large nginx must have happened when I updated the php t 7.0

Do you think this could have caused the problems??

Cheers Roger

That error is usually when JSON.parse is given data that isn’t valid JSON.

I’m not really sure I see how updating PHP would cause the issue you are having. But I guess anything is possible. It seems more like a theme or plugin incompatibility with the server settings.

If you did have server access you might try increasing the large_client_header_buffers in the nginx.conf file. Although, I’m guessing you would need admin access to change and reload the config.


I’d also suggest you try the support again on Monday as the support might be slightly better on weekdays.

Thanks I also think that the ISP could change the nginx.conf file but they are lazy buggers and it is to much trouble for them.

Thanks again

Roger