Account Reset Randomly- Issue


#1

I have been using FreeCodeCamp for about 2 weeks on Google Chrome and yesterday my tab on which I had opened the FreeCodeCamp website on crashed and would keep crashing even after multiple reloads. I tried on a different browser and it worked but my account had been reset and I went from 235 points to 0. Please help :slight_smile:
Thank you!


#2

There are two different types of progress being saved going on at Free Code Camp: your profile and your browser cache.

Your completed challenges are all saved to your account in the FCC database. You can see the list of completed challenges and also the last submitted solutions by looking at your profile page.

If your profile does not include your completed challenges (as in this case), here is my troubleshooting advice:

  1. Double check that you used the same method to sign in. Try logging out and back in again with the original method.
  2. Double check that you aren’t on the beta site now and that you didn’t create your original account on the beta site by accident. (Yes, this does happen.)
  3. Contact team@freecodecamp.com . The most likely scenario is that your account got duplicated when you signed in and you are being logged into the new one. When that happens, someone on the team can merge your accounts. Please be patient when emailing the team. Remember that there are thousands of campers, a small team, and this is all volunteer-driven.

Your progress tracking (map) is saved in your browser’s local storage. In-progress code is also saved in your local browser cache. If you are changing browsers or clearing your cache regularly you’ll have to use freecodecamp.com/map to navigate to your next challenge. Especially as you get to more complicated challenges that may take multiple sessions, I strongly recommend saving your in-progress work outside of the browser cache. This is a good opportunity to learn the ins and outs of your GitHub account, but you can also just save locally or use a service like repl.it which allows for versioning.


#3

@ArielLeslie This user is not experiencing a browser cache user.


#4

@HassanQureshi It looks like there may be a legitimate account issue. Please email team@freecodecamp.com and someone will get this resolved for you.


#5

Note “(as in this case)”