Add Submit Button Glitch

Is there a glitch with this module? I can’t seem to get this to work with the hints provided.

The test that is failing is:

"Your submit button should only have the text “Submit”.

Code is…

<input type="text" placeholder="cat photo URL">
<button type="submit">Submit</button>
</form>

What is your code? What tests are failing?


When you enter a code block into the forum, precede it with a line of three backticks and follow it with a line of three backticks to make easier to read. See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

markdown_Forums

Updated my post to clarify…

Try resetting the challenge and putting your code in again. There is a known bug in some of the early challenges where the tests fail to update.

Thanks. I tried that again, but it’s still not working.

Just skip it then. You can use the map to jump to the next challenge.

Would you mind posting all of your code and not just the three lines you posted originally?

Randel, my code

<link href="https://fonts.googleapis.com/css?family=Lobster" rel="stylesheet" type="text/css">
<style>
  .red-text {
    color: red;
  }

  h2 {
    font-family: Lobster, Monospace;
  }

  p {
    font-size: 16px;
    font-family: Monospace;
  }

  .thick-green-border {
    border-color: green;
    border-width: 10px;
    border-style: solid;
    border-radius: 50%;
  }

  .smaller-image {
    width: 100px;
  }
</style>

<h2 class="red-text">CatPhotoApp</h2>

<p>Click here for <a href="#">cat photos</a>.</p>

<a href="#"><img class="smaller-image thick-green-border" alt="A cute orange cat lying on its back. " src="https://bit.ly/fcc-relaxing-cat"></a>

<p>Things cats love:</p>
<ul>
  <li>cat nip</li>
  <li>laser pointers</li>
  <li>lasagna</li>
</ul>
<p>Top 3 things cats hate:</p>
<ol>
  <li>flea treatment</li>
  <li>thunder</li>
  <li>other cats</li>
</ol>
<form action="/submit-cat-photo">
  <input type="text" placeholder="cat photo URL">
  <button type="submit">Submit</button>
</form>

Your browser information:

Your Browser User Agent is: ```Chrome

Link to the challenge:
https://www.freecodecamp.org/challenges/add-a-submit-button-to-a-form

OK, that code passes the tests when I run it on my Chrome browser. Not sure why you can not pass the tests. If you are on Windows you might try Ctrl+F5 to see if that helps any before running the tests. It will refresh but clear the cache.

Thanks. I tried Ctrl+F5 before and it didn’t help. I opened the page in Microsoft Edge and it passed the test. I was originally working in Chrome in a Windows system.

Thanks for your help!