Adding licence to package.json not working

I added the “licence” key to the package.json file on my Repl.it repository but the FCC tests keep failing. I tried “licence”: “UNLICENSED” or “licence”: “MIT” with no success.

Is there a bug in the FCC challenge test? Am I missing something?
(it is the last challenge that I haven’t passed in the “Managing package with NPM” section)

My package.json file:

{
	"name": "fcc-learn-npm-package-json",
	"author": "Olivier Deloubriere",
	"description": "this is my first Node.js project",
	"licence": "UNLICENSED",
	"keywords": [
		"first",
		"freecodecamp"
	],
	"version": "1.0.0",
	"dependencies": {
		"express": "^4.14.0"
	},
	"main": "server.js",
	"scripts": {
		"start": "node server.js"
	},
	"repository": {
		"type": "git",
		"url": "https://idontknow/todo.git"
	}
}

I am using Brave V1.21.74, it also fails with Chrome.

Challenge: Add a License to Your package.json

Link to the challenge:

Have you tried:

Fill the license field in the package.json file of your project as you find suitable.


I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).

Thanks for the tip about formatting the code lines.

In the meantime I found my error: I had misspelled license (“licence” with a “c” like in French…). It is now working correctly.