Adjust the Hover State of an Anchor Tag (bug?)

Tell us what’s happening:

I’ve checked a previous post, my answer should have no problem.

The second test passes all the time, but the first test says the anchor text should remain black. Mine is black in fact, but the test fails any ways.

Your code so far

Cannot post the challenge link due to the status of a new account.


<style>
  a {
    color: #000;
  }
  a:hover {
    color: blue;
  }
</style>
<a href="http://freecatphotoapp.com/" target="_blank">CatPhotoApp</a>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0.

Link to the challenge:

What browser are you using? What version is it on?
Your code passes when I run the tests.

I’m using Firefox on macOS, with the latest version 66.0.5 (64-bit).
I also tried it with private mode, still failed.

Just run it in Safari, it works now.

It is succeeding in both the latest Firefox and latest Chrome fro Windows. I know that Firefox has been having some messed up updates lately, so I wonder if their most recent Mac update caused a problem.

1 Like

It could be. I should’ve tried more browsers before posting here.
Thanks for the info and your kindness!