Apache HTTP XAMPP server shows 10+ icons and shows error message when trying to quit all of them

This is all of the icons

image

This is what it shows when I try to QUIT the icon.

image

This is Windows 10 right?

Did you install XAMPP as administrator and is it running as an admin?

Without further investigation, it seems like a permissions issue.

I haven’t tried XAMPP in a long time (think WinXP days). I use WAMP without any issues though.

Typically, when on a “basic” or “limited” user account in Windows, you should install apps and software as the administrator or using an account that is a member of the administrators group.

Then set the permissions for the users.

Then run the app under a non-administrator account.

A lot of people just make a Windows user account and add it to the administrators group and then use that account all the time as their main account.

Although, there are security implications with that. For my home PC, I am guilty of doing this too out of laziness/convenience.

Maybe this link is helpful:

XAMPP Control.ini Access Denied

I am running it as admin but the icons do not disappear. and now there are even more icons.

image

I see you’ve marked this as solution but have replied with the icon issue. So I am not clear if it is solved or not.

Perhaps the config.ini is corrupted or misconfigured.

You could try:

  • Closing xampp and deleting the control.ini. It should be “automagically” regenerated when you run xampp again.

  • Uninstalling xampp and re-installing it as an administrator or an account with administrator privileges

I am not very familiar with xampp, haven’t used it in over 10ys. I switched to WAMP because it comes with MySQL pre-bundled. But WAMP requires a lot of specific Microsoft VC++ runtime versions to be installed before installing WAMP, so it takes a while to install all the one’s you don’t have on your system already.

if you are still having the issue, you could always try the xampp forums.

XAMPP for Windows

I solved it already this moring (EST time zone)

Oh, OK good…glad it’s working!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.