APIs and Microservices curriculum failing

Please format code snippets in your forum posts.

Here is a brief post that explains everything you need to know about formatting your messages in the forum:

To your problem:

I could not copy your posted code because of the missing formatting. (the quotes are not recognized).

I also can’t spot any obvious issue apart from the file name which should be “package.json” and not “Package.json” (I guess this was just a typo).

This package.json content worked for me:

{
	"name": "fcc-learn-npm-package-json",
	"author": "Dennis",
	"dependencies": {
		"express": "^4.14.0"
	},
	"main": "server.js",
	"scripts": {
		"start": "node server.js"
	},
	"repository": {
		"type": "git",
		"url": "https://idontknow/todo.git"
	}
}

Maybe you try this in your replit, it should work if there is not another issue with your project.

best
Dennis

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).

Thanks for the quick responses Dennis. Unfortunately there must be another problem. I have the exact same error when I override the package.json content with your code snippet, just the same as if I use the problem solution content from FCC.

Thank you for the markup tips. That’s good to know!

I would suggest you freshly fork the project. I guess you changed something unintentionally.

I have used the following method in the exercise description to make several different forks on Replit:

On each occurrence I have come to the same error message after altering the package.json file:

“package.json should have a valid “author” key”

I am running pressing run and copying the link provided above the simulation. I honestly don’t know what I could be doing wrong.

Thanks for trying to help!

can you give the link to your project? (not the Live Preview link) so we can check?

I even attempted forking with gitHub, cloning, changing package.json locally, pushing and then uploading to replit via gitHub. Once again the same error.

Sure.

do you also have the replit project link?

Here’s the link above. I went ahead and made the replit public in case you couldn’t see it.

@Nick-W If you run the project and open it up in a new tab does it load for you? It doesn’t seem to work for me.

This might sound silly but can you try creating a new free account and see if it works on that account. I believe the pay accounts are on their own cluster so it’s just a test to see if using a free account will change your project location.

You’re not alone in having these issues with Replit. I had the exact same problem on Friday, I could even copy-paste the solution provided and it wouldn’t work. Eventually, after forking the project and trying over and over again, I guess I got lucky and it worked. It certainly wasn’t my code, because I was copy-pasting the whole file every time, changing nothing. I continued to experience an exciting variety of issues with replit throughout the day.

I actually ended up on the forum today because I am trying to start the “Basic Node and Express” section, and the Replit is refusing to run the forked code. (zero modification, throws an error) Enough page refreshes and re-forks and it eventually started running.

Basically, you’re not crazy, Replit is just being buggy. Keep trying, it’ll eventually work (probably). Or complete it locally and find somewhere to host it? Maybe run it locally with Apache and tunnel out with ngrok? :confused:

update
So I do believe I’ve found a process that gets replit to work:

  1. fork the project
  2. try running the project (it will fail)
  3. click the “open in new tab” icon to the right of the URL (in the editor)
  4. try running the project again (this time it should run)

Now you can make changes. The refresh button doesn’t appear to work however, so you’ll have to stop/start the project again for your changes to be reflected.

I’ve also discovered another replit bug, which is that, in “my repls” all the replits you’ve created can’t be deleted. The settings button both opens a menu and acts as a link taking you to the project.

1 Like

I know, it’s super annoying. I’m sure it must have been reported so I would imagine it is getting fixed.

You can delete the repl by opening it and clicking the name on the top left, then click the 3 dots and use delete from the menu.

delete

1 Like

Haha I see you’ve had the runaround with Replit too! This is my first time using this website and I can’t say I’m impressed with it’s current state. So today I’m encountering a whole new host of issues myself.

Running the projects is no longer working at all (they were yesterday). Forking does not seem to come to the rescue in my case. Nor does creating a new account. Fortunately, the one thing which didn’t work yesterday (deleting my repls) is now working! Hopefully the fix the rest of the issues soon!

Unfortunately, it doesn’t really matter which service we use for the projects, there will always be issues. We used to use Glitch before switching to Replit.

You can try using Glitch it isn’t much different from Replit and should work just fine. When you create a new project you have the option to import from GitHub and you just give it the starter project GitHub URL.

Yep worked first time with Glitch. Thank you SO much. Maybe worth directing people to this method while Replit is being buggy. Hopefully they fix their end soon.

1 Like

Seeing as you are paying for the hacker tier on Replit I might also suggest you try raising an issue with support.

I’m not really sure how I achieved that tier. I certainly haven’t payed a cent…
Another bug?

I’m editing this post because as a new user I’m not allowed to post for the 9th time in the first day.

To answer your subsequent question - no, my second account has a basic rank. Weird!

Interesting, maybe they give new accounts a trial run. Did your second account also get that tier?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.