Arithmetic Formatter pytest module: old problem, new solutions

Arithmetic Formatter pytest module error:

Old problems, new solutions
purple divider

It seems like the problem with pytest module in Arithmetic Formatter is happening again. I’ve tried some old solutions around there in the forum, none of them worked. Just adding the package ‘pkgs.python38Packages.pytest’ on ‘deps’ is not working anymore, no matter how you try it. But I found a new way to solve this and wanted to share with you guys.

Installing poetry

I saw this in replies of a topic about this problem in this forum, but it doens’t tells you how to do it, so I decided to share this piece:

curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/install-poetry.py | python -

(it goes on Replit Shell’s)

Update poetry

I think it will be also necessary, at least in my case it was. So you can also give Replit Shell’s this piece:

poetry update

It’s all folks!

At least for me it was… any of you guys from staff could test it so let me know if the problem persists and it needs more pieces.

4 Likes

Hello! It seems that link doesn’t work anymore, I’m getting a 404 error on Replit shell. How should I proceed? (edit: another user answered in a different post, “pip install pytest”)
~/boilerplate-arithmetic-formatter$ curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/install-poetry.py | python -
File “”, line 1
404: Not Found
^^^
SyntaxError: illegal target for annotation

2 Likes

Hi! guys I have the same issue and this does not work anymore, so I can not run it to test it, even it was not possible for me to select “use run command” at the beginning becasue there was not such button. Could you help us please?