Assignment with a Returned Value Will not "Run the test"

Assignment with a Returned Value Will not "Run the test"
0

#1

Tell us what’s happening:
Whenever I am ready to “Run the Tests” The button seems dead and there is no response to tell me if I am correct or not. Its as if it is a dead link. I have refreshed the page and cleared my code several times and have clicked “Run the Tests”. It only seems to go dead once I start to write out my answer. Anyone having the same issue?

Your code so far


// Example
var changed = 0;

function change(num) {
  return (num + 5) / 3;
}

changed = change(10);

// Setup
var processed = 0;

function processArg(num) {
  return (num + 3) / 5;
}

// Only change code below this line
processed = processedArg(7);

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/javascript-algorithms-and-data-structures/basic-javascript/assignment-with-a-returned-value/


#2

I don’t know if this will solve your problem, but you have a typo between processArg and processedArg


#3

Youre right and when I fixed it I get the check mark but sometimes the “Run the Tests” button doesn’t run any tests and I don’t know if its because I am wrong or if it just isn’t responding. I would like it to rerun the test everytime I click “Run the tests”


#4

Have you tried to console.log and look what’s happening in devtools? The freecodecamp console won’t show you anything but their results.


#5

Hi @Livezigzagging,

Try another web browser because some browser not working in some examples, so if you stuck, try Chrome browser or Firefox browser or Edge browser.

Regards,
Ali Mosaad


#6

Good idea Ill have a look.


#7

@ali-admin I am using Chrome an prefer it to other browsers. Thanks for the tip however, I may convert to Firefox.