Authentication with Socket.IO error with passport.socketio and cookie-parser

Tell us what’s happening:
When I test my code with I get the following errors on FCC:
passport.socketio should be a dependency. (Test timed out)
cookie-parser should be a dependency. (Test timed out)
passportSocketIo should be properly required. (Test timed out)
passportSocketIo should be properly setup. (Test timed out)

I tried everything and even read the forums to see if I could figure it out. I even tried using the code on the example that was given and all get is errors on my console.
I was wondering if this was some type of bug on FCC since I used 2 different platforms to type my code (replit and glitch). Regardless, I decided to move on and skip this challenge since I only have 3 left in this section. Now I assume that I can’t pass any of the 3 challenges if this specific one doesn’t pass. Below is my code. I followed the directions on how to set up "passport.socketio@~3.7.0 , connect-mongo@~3.2.0 , and cookie-parser@~1.4.5 as dependencies`".
Please help if anyone can. Thanks.
Your project link(s)


Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36

Challenge: Authentication with Socket.IO

Link to the challenge:

Here is my code again on glitch:

That link doesn’t work so here’s this one:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.