Autotester not passing correct answer

I’m doing the Student Database: Part 2
AVG will give you the average of all the values in a column. Use it to see the average of the same column.”
I’m typing the correct code but I’m not passing the test.
What can I do?

Screenshot:

(You might not see the underscore in “major_id”, but it is there)
Notice I do get the query back but codeRoad doesn’t even flinch

I’ve tried reset, soft reset, changing computers, changing browsers, hitting “exit” in the terminal and trying again. Everything to no avail

Do you guys think it’s time for the last resort???

Last resort:

If all else fails, you can delete your container and start over

As a last resort, you can go to your CodeAlly dashboard and delete the container with the name of the tutorial that is problematic. Unfortunately, you will have to start the tutorial from the beginning if you do this. Note: the dashboard may not update until you refresh the page.

Have you tried clicking “run” after entering the correct command? I have run into a similar problem a couple times. When it didn’t automatically respond, I clicked “run” to run the test manually, and it worked.

I have. it says something like test fail

Check/Re-submit next day after logging in a new browser session. This happens… some bugs are there in the connection and I think CodeAlly is often down due to some necessary maintenance particularly during weekend… Get’s solved by Monday/Tuesday usually for me. No issue with code, I checked my session in which this had passed, exact same code yours’e gives same result as yours’e.

Thanks for your response.
I tried it again. It didn’t work :frowning:
This time I used a different computer, with a different OS.
I took the screenshot right after manually clicking the “Run” button.
It says “test runner failed”
Here’s a screenshot:

bad…
FYI… there are few lessons that require ‘time’ matching. My Arch Linux systems has some time problem so that exercise was failing… but same thing run on Windows worked… so watch out for such thing if you come across it!

All the best

Does anyone know what “Test Runner Failed” mean? or a way of getting more info on the test runner error? or a way of restarting the test runner?
haha idk… I wouldn’t like to “delete the container with the name of the tutorial”. that would mean I would’ve to re-do everything again. :grimacing:

Check out similar error in this thread

Thank you for your response. I read the thread unfortunately I wasn’t that lucky or that smart.
1 - I copied students.sql and student_info.sh locally
2 - Tried deleting the files on the webapp (right-click then “delete”)
3 - That didn’t work so I went to: CodeRoad - Menu - Settings - reset
4 - Refresh the page…

To my surprise the files were still there! Intact! Same lines of code as my local copy! But CodeRoad did reset to first level and still not working…
Check the screenshot:
image

I guess I can close this topic now. Thank you all for your replies.
I ended up erasing the container in the codeally dashboard.
Here’s my test runner working again:


:sweat:

1 Like