Ayuda Step26 Formularios HTML

Cuéntanos qué está pasando:
Describe tu problema en detalle aquí.
Después de intentar varias opciones, estoy atascado en este paso.
He intentado todo cuanto aparece en los post del foro, a pesar de saber que “terms and conditions” deben ir después del enlace envueltos por la etiqueta <a>, poniendo la etiqueta de cierre </a> después de terms&conditions,incluso he agregado el atributo target:_blank …
Es algo sencillo, lo recuerdo del 1er. proyecto, pero no consigo resolver.
Saludos

   **Tu código hasta el momento**
/* file: index.html */
<!DOCTYPE html>
<html>
 <head>
   <title>Registration Form</title>
	  <link rel="stylesheet" href="styles.css" />
 </head>
 <body>
   <h1>Registration Form</h1>
   <p>Please fill out this form with the required information</p>
   <form action='https://register-demo.freecodecamp.org'>
     <fieldset>
       <label>Enter Your First Name: <input type="text" required /></label>
       <label>Enter Your Last Name: <input type="text" required /></label>
       <label>Enter Your Email: <input type="email" required /></label>
       <label>Create a New Password: <input type="password" pattern="[a-z0-5]{8,}" required /></label>
     </fieldset>
     <fieldset>
       <label><input type="radio" name="account-type" /> Personal Account</label>
       <label><input type="radio" name="account-type" /> Business Account</label>
       <label><input type="checkbox" required /> I accept the<a href="https://www.freecodecamp.org/news/terms-of-service"/> terms and conditions</label>
     </fieldset>
     <fieldset></fieldset>
     <input type="submit" value="Submit" />
   </form>
 </body>
</html>
/* file: styles.css */
body {
 width: 100%;
 height: 100vh;
 margin: 0;
 background-color: #1b1b32;
	color: #f5f6f7;
}

label {
	display: block;
	margin: 0.5rem 0;
}

   **Información de tu navegador:**

El agente de usuario es: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

Desafío: Step 26

A tu código le falta la etiqueta de cierre </a>
y tambien tienes errores en el espaciado
Tu codigo se ve asi

<a> soy un link</a>

Cuando deberia ser así:

<a>soy un link</a>

Entre la etiqueta de apertura y la primera letra no deberia haber espacios.

hay que tener cuidado con los espacios, mayusculas, signos de puntuacion, etc…