Back End Development and APIs: How to Get Started?

Hi! I am trying to get started with the Back End Development and APIs course, I have read other threads but still can’t really figure out how to get started.

I have: cloned the Github repository for the boilerplate-npm, edited the package.json file to add an author, pushed the changes, loaded the boilerplate-npm project with changes into replit. I try to click run, but it errors out. I try submitting the browser URL link to the project, but it fails to pass the test. It also says “Remember to submit the Live App URL.” without ever explaining what that means.

Here’s what I get when I click run on replit:

npm start

> start
> node server.js

  throw err;

Error: Cannot find module 'express'
Require stack:
- /home/runner/boilerplate-npm/server.js
    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
    at Function.Module._load (node:internal/modules/cjs/loader:778:27)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at require (node:internal/modules/cjs/helpers:94:18)
    at Object.<anonymous> (/home/runner/boilerplate-npm/server.js:9:15)
    at Module._compile (node:internal/modules/cjs/loader:1101:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:79:12) {
  requireStack: [ '/home/runner/boilerplate-npm/server.js' ]
exit status 1

I also tried loading and running on glitch, but it just seemed to time out. I even published it on replit and tried submitting this link too (no dice.)

I’m a complete beginner to all of this, so pardon me if I am missing something obvious. It seems to me like there should be a slightly more thorough, walkthrough-esque explanation about how to get started with this first step for dimwits like me. :wink:

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0

Challenge: Managing Packages with NPM - How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

I’m having the same issue :confused:
I pasted the GitHub Pages link with the live demo and the message “Remember to submit the Live App URL.” disappeared, but even so it didn’t work.

I tried it on after reading other posts and it works there.


Huh! It works now on glitch for me too, even though I did nothing different from last night.

Maybe it was just down. Thanks!

1 Like

There are some recent changes on replit that have complicated some things. To get it working there, you should just need to click the shell tab next to the console - and run npm install in there. That used to run automatically, now it doesn’t - so you are seeing the “Cannot find module” error.

1 Like ended up working for me :+1: