Back End Development and APIs Projects - Exercise Tracker

Tell us what’s happening:
Describe your issue in detail here.

Your project link(s)

solution: boilerplate-project-exercisetracker - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Back End Development and APIs Projects - Exercise Tracker

Link to the challenge:


The Code is unable to pass the last test. I have checked the outputs and everything seems fine. Also checked the network tab and nothing seems wrong.
Can anyone help me ?

One issue is that when you specify the request query string parameter limit, the count value needs to be limit (when the limit is less than the count) or count (in case count is less than the limit or no limit is specified).

Not sure why it is timing out, if I fork it and use my own DB it passes.

  1. Try using a VPN, or try using a different geographical location like the EU or US when creating the cluster.

  2. Try it on Glitch.


@prasadsaya If I understand what you are saying then the test doesn’t check for that. I was thinking the same at first that the count property should change depending on the length of the log array.

The test only checks if it’s an array and its length.

Tried that already.Didn’t work

Ok. It seemed like something is wrong with the test , because I ran the test on the console of that page and it seemed fine . I am unable to find what is going wrong with the tests.
Even tried a vpn. Doesnt solve it.

It’s not likely to be the test as it passes for me with your code as I said. Try it on Glitch and see if that works.

Did you try using a different cluster location?

I forked as @lasjorg did with my own database credentials and all tests pass. I also submitted your project url (https://boilerplate-project-exercisetracker.paradoxpd.repl.co) and it passes all the tests.

It is passing for me now as well, it was timing out before.

@ParadoxPD Did you change anything?

Then what is happening with my computer, I dont get it . I have in at it for literally 8 hrs now and it still fails at a particular test.

Yes I started the replit server again but it still fails for me . I have tried glitch , but still the same issue.

Some one send me their link , let me try that.

image

image

Try the demo

https://exercise-tracker.freecodecamp.rocks/

I still think you should try switching the cluster location if you haven’t.

Changed my cluster location. But still the same

Submit the demo. The first test should fail, but all the others should not.

Yes that works fine .

Let me create a new project in mongo and a new cluster.

Did you try using Glitch yet?

Yes tried with glitch.
https://prism-cherry-timpani.glitch.me/

Did it pass with the Glitch version?

Nope It has the same issue. Just the last test is getting timed out.

Can you send me your replit version so i can try that.

The following is after forking your replit and using my Mongo Atlas credentials:

https://boilerplate-project-exercisetracker.rmdawson.repl.co