Back End Development and APIs Projects - Timestamp Microservice

Tell us what’s happening:
I can’t pass the last 2 tests of the challenge. Perhaps it’s a time zone issue but I don’t know how to solve it. Could you help please?

Your project link(s)
https://boilerplate-project-timestamp.mariamawitashen.repl.co

solution link: boilerplate-project-timestamp - Replit

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36

Challenge: Back End Development and APIs Projects - Timestamp Microservice

Link to the challenge:

Your code is passing for me. It shouldn’t be a timezone issue but it might be a daylight-saving issue. Make sure not to submit the project near midnight.

I actually had an issue with timing for this one too. I went to bed one night and woke up the next morning and submitted again and it passed that time, without making any changes from the night before.

@lasjorg and @Salathor , thank you both for your quick reply.
I tried running the test at different time of the day for 2 days now and I still can’t pass the last two tests. I know it has something to do with using new Date() to get current time on replit. I wasn’t able to pass the Chain Middleware to Create a Time Server challenge for this same reason.
I also tried to run the code locally with http://localhost: port . And although the app works on my browser, fcc can’t access it. Idk how to continue.

Your project passes for me, on replit.com.

If it’s just the last two tests that are failing, then that likely means that you have a time configuration problem on your local computer (since the tests run locally and your time is set incorrectly) or you have some connectivity problems since the tests allow for a discrepancy of up to 20 seconds between the local and server times.

Thanks @jeremy.a.gray you are right. The time on my pc was set manually. When I set it automatically I was able to pass the last tests :wink: