Basic Node and Express - Not Found

Hi guys,

Having trouble here with the second block of exercises from API course. I believe I had the same port 3000 problem initially.
I looked into most of the forum and nothing worked, but I went with the killing of the process for port 3000, I used “sudo lsof -t -i:3000” and “kill ” which got me to the current situation:


As you can see the browser still can’t connect to the page that’s used to check on the code progress. My port is not open and connects to the address.

Does any one have a clue what to do here? I’m very ignorant still on all of this so I’m sorry if I’m being dumb in anyway on this.

Thanks!

Which part of the challenge set are you currently on? And can you show me what the contents of your directory is, and the contents of your myApp.js file please?

Hi!

I’m on the second course pack of Back End and API. Finished “Managing Packages with NPM” and I’m trying to do “Basic Node and Express”, but I can’t start since that connection won’t happen. However when I try to launch " MongoDB and Mongoose" the third course I have no issues opening the web address that does the linking between what I do in the terminal and the validation on the FCC course tracker.

How do I show you the contents of the directory? Is is this enough or do you need to see a specific file or folder?

s

I tried the suggested solution here: “You have to stop the node server by entering Ctrl + C. Then a bash prompt appears, where you type npm start.”

it didn’t work, it still remains “Not Found” on the simple browser window.

also tried the solution suggested in this glitch.

changed the myApp.js and nothing happened.

You don’t seem to be far along enough in the “Basic Node and Express” to be serving anything that can be found in the browser. In step 3, you send the HTML file in the views folder to the browser. In the prior step you send a string instead. But trust me on this, the app is more than likely running in the background.

Hope this helps.