Bugged Challenges

Since about 15 minutes ago, a couple seconds after I start inputting anything into any of the challenges, the entire challenge breaks - nothing is really responsive, and the console immediately freezes. (I first tried with the JS caesar certificate challenge, but it seems like anything I try results in the same behavior)

Is this just me?


Its possible to get this behavior with an infinite loop. Hard to know for sure what’s going on without your code to try to reproduce this.

I’m pretty sure it’s just my wifi acting up so I’ll give it a restart and see what happens

All of the Javascript challenges are like this right now. The console will stop updating after a couple of seconds and you cannot submit any challenges. Has nothing to do with using loops, and happens with any code, or even no code.


My browser is not doing this. It doesn’t seem like it is happening to everyone. We need specific details to be able to reproduce. Which challenges, what code are you using, what browser are you using, what browser extensions are you using, etc.

Deleted my previous post because I think I was mistaken.

Some more info:

This only appears to happen when the console runs something that results in an error. Even after fixing the code, it will not update the console at all. It happens in both Firefox and Microsoft Edge without any extensions enabled on either.

Video of the issue in action: Imgur


I am having the same issue. Using Chrome and tried Firefox. Same issue for both. (https://www.freecodecamp.org/learn/javascript-algorithms-and-data-structures/functional-programming/use-the-filter-method-to-extract-data-from-an-array)

1 Like

please see responses in “Bugged Challenges” feed.

1 Like

Yes. I am seeing responses with partial information.

It happens on all Javascript challenges using any code in any browser after the console reports an error.

1 Like

Which challenges: javascript algorithms and data structures. Multiple sections, but here is one example: (https://www.freecodecamp.org/learn/javascript-algorithms-and-data-structures/functional-programming/use-the-filter-method-to-extract-data-from-an-array)
what code are you using: what does that mean?
what browser are you using: firefox and chrome
what browser extensions are you using, etc.: none

1 Like

The video is the most useful part. Thanks for that.

This is happening with me too, on all browsers, Edge, Chrome, FF, FF(Dev), and even PaleMoon.

I just started the JS DSA, and the first step where you learn comments won’t even run. I know how to write comments…

// comment 

/* comments comments
comments comments */

Tried disabling any dark themes, tried hard refresh, tried enabling all permissions, and yea…

(FYI, yesterday I got thru the HTML section w/o issue.)

confirmed here too not working.

Im doin the java script one and now after i type the code i need to refresh the browser for the console to read. it wont read automaticaly.

1 Like

No, I, as well as several of my classmates, have reported the same issue. After inputting a certain amount of characters, it seems to glitch out and not allow me to interact with anything but the section where the code is inputted. I am not sure what may cause this issue, but it has caused some strange behaviours. Reloading the page allows you to interact with the buttons again, though I cannot say why.


A fix has been pushed to production and should be taking effect soon


For me this is still an issue. I’ve tried on a few browsers with same results. This only seems to happen when it encounters a syntax error error as below.

SyntaxError: unknown: Unexpected token (1:12)

1 | console.log(

Yeah, this is still happening for me too.

A fix has been pushed to production and should be taking effect soon

Hi friends,

Thank you for your patience. This fix is now live and you should no longer see the issue.

Note that you may need to refresh and clear your cache.