Build a Product Landing Page Video problem

Tell us what’s happening:
I have 2 tests failing and I am sure it is something to do with the video in my code but I’m unable to figure out what it is after many tries.

Your code so far

<script src="https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js"></script>

<div>
  <header id="header">
    <div>
      <img id="header-img" src="https://pmcvariety.files.wordpress.com/2018/01/amazon-logo.jpg?w=1000&h=562&crop=1" alt="Amazon Logo" />
    </div>

    <nav id="nav-bar">
      <ul>
        <li><a class="nav-link" href="#clothing">Clothing</a></li>
        <li><a class="nav-link" href="#entertainment">Entertainment</a></li>
        <li><a class="nav-link" href="#electronics">Electronics</a></li>
        <li><a class="nav-link" href="#h&k">Home & Kitchen</a></li>
        <li><a class="nav-link" href="#Best-sellers">Best Sellers</a></li>
      </ul>
    </nav>
  </header>

  <section>
    <iframe id="video" width="560" height="315" src="https://www.youtube.com/embed/NrmMk1Myrxc" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen>
</iframe>
  </section>

  <section>
    <form id="form" action="https://www.freecodecamp.com/email-submit">
      <input name="email" id="email" type="email" placeholder="Enter your email address" required />
      <input type="submit" id="submit" value="Get started" />
    </form>
  </section>

</div>

Hello Camper!

For now, the test suite only works in Chrome! Please read the README below in the JS Editor before beginning. Feel free to delete this message once you have read it. Good luck and Happy Coding! 

- The freeCodeCamp Team 

-->

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36.

Link to the challenge:

If you click on the Tests button after running them, you can see what and why fails.
Hint: it’s not the video code.

Thank You! I didn’t know we could see which tests are passing and failing. But now I know!