Build a Survey Form radio buttons

Build a Survey Form radio buttons
0.0 0

#1

Tell us what’s happening:
The first label in the list isn’t showing up and the first radio button is on the line above.

Your code so far


<script src="https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js"></script>

<!-- 

Hello Camper!

For now, the test suite only works in Chrome! Please read the README below in the JS Editor before beginning. Feel free to delete this message once you have read it. Good luck and Happy Coding! 

- The freeCodeCamp Team 

-->

<main>
  <h1 id="title">Pump and Seal Environment</h1>
  <p id="description">Information Data Form</p>
  <form id="survey-form">
    <div>
      <label id="name-label" for="name">* Name:</label>      
      <input type="text" name="name" id="name" class="input-field" placeholder="Enter your name" required>
    </div>
    <div>
      <label id="email-label" for="email">* Email:</label>
      <input type="email" name="email" id="email" class="input-field" placeholder="Enter your email" required>
    </div>
    <div>
      <label id="number-label" for="age">* Age:</label>
      <input type="number" name="number" id="number" class="input-field" min="0" max="9" placeholder="Enter your age" required>
    </div>
    <div>
      <label id="dropdown-label" for="country">* Country:</label>
      <select id="dropdown" name="country" class="input-field" required>
        <option disabled value>Select an option</option>
        <option value="united states">United States</option>
        <option value="canada">Canada</option>
        <option value="mexico">Mexico</option>
    </div>
      <div>
        <ul>
          <li class="radio"><label>Single Seal<input name="radio-buttons" value="1" type="radio" class=seal-type></label></li>
          <li class="radio"><label>Double Seal<input name="radio-buttons" value="2" type="radio" class=seal-type></label></li>
          <li class="radio"><label>Tandem Seal<input name="radio-buttons" value="2" type="radio" class=seal-type></label></li>
        </ul>
      </div>
  </form>
</main>


Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/responsive-web-design/responsive-web-design-projects/build-a-survey-form


#2

Could it be to do with the missing " " between your class seal-type?


#3

Didn’t notice that, but it was actually because I hadn’t closed my select element.