Cannot GET / - Advanced Node and Express

Tell us what’s happening:
I’m on Implement the Serialization of a Passport User. I pass the tests, but when I run my app, I get a screen that says “Cannot GET /”. I even tried copy pasting the code from the FCC Github repo, and I got the same problem.

Your project link(s)

solution: https://replit.com/@ahmedabbas666/Advanced-Node-Tutorial

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36.

Challenge: Implement the Serialization of a Passport User

Link to the challenge:

1 Like

Ok, so for some reason it seems to work when I put the listener inside the DB code

1 Like

Welcome there,

If I fork your project, and change server.js to the expected solution, I can see the Cannot GET / error in the PIP (picture-in-picture) browser, but not if I open the page in a new tab:

This has affected previous challenges, and there is a specific warning about it in a later challenge: https://www.freecodecamp.org/learn/quality-assurance/advanced-node-and-express/registration-of-new-users

NOTE: From this point onwards, issues can arise relating to the use of the picture-in-picture browser. If you are using an online IDE which offers a preview of the app within the editor, it is recommended to open this preview in a new tab.

In general, though, it should not affect the tests.

Hope this helps

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.