Cannot log in to my account

This problem is happening to me as well. When I sign in and click “Go to the coding curriculum”, the opened page logs me out and takes me to the first HTML challenge. When I attempt to log in from there, I’m taken back to the welcome page.


Forum accounts and FCC accounts are completely different. FCC probably already has your email address associated with your account, so try logging in by providing your email address and using the code that is sent to you.

This problem is occurring while attempting to sign in to the FreeCodeCamp website and not while signing in to the forum.

Yes. I know. The fact that you can log in to the forum with your GitHub credentials has nothing at all to do with logging in to your FCC account.

To be clear, I signed in using my e-mail address and this problem occurred.

Solution: I signed out by going to the “settings” page then signed back in using my e-mail and verification code. Clicking “Learn” and then “Explore the Curriculum” now reflects my previous FCC work. Thanks for the help!

1 Like

I’m glad everything is working for you now. Thanks for your understanding and patience with the transition. Happy coding!

A more accurate answer is that I assumed I signed in by providing my e-mail, when actually I just gave my e-mail to FCC for the first time while signing in using Github. I hope this helps others!

I just logged in using my email, and everything seems to be in order. Thanks for your help.

Glad to hear it. Happy coding!

Hi. I have another query though. Earlier I could see the whole map, where all the activities and certificates available were listed. Now, however, I can only see the curriculum, and seems like the setup has changed. I was on the learnyoumongo stage, and now I can’t seem to record my progress. Has the back-end development changed to APIs and Microservices?
And why are my older certificates called legacy certificates? Are new types of certificates being issued?

When you are in a challenge and you click the curriculum button, it shows you the challenges for the section you’re currently in. You can always see the entire curriculum by going to Learn and clicking the Explore the curriculum button.

Hi @ArielLeslie . Sorry to disturb again. Actually I’m figuring out all the new features after the renovation. Can we not print our legacy certificates anymore? Also, whenever I switch to curriculum after logging in, I seem to get logged out. Thanks again.

Sure you can.

I tried printing it using Ctrl+P. Printing is blocked in the code. Also, I can’t log in anymore. Everytime I log in using a new passcode, the settings page opens. And then when I move to the curriculum page, I am logged out, and can’t proceed further.

You can report the inability to print as a GitHub Issue. In the meantime, you could use a screenshot.

It seems that something happened in the last hour or so that is causing everyone to keep getting logged out. I know it’s frustrating and appreciate your patience.

Ok. That’s fine if the logging out thing is a bug.
And I have found the cause for not being able to print properly. There is a part in the style tags which prevent printing right at the top. I’ll post it in the issue.
Thanks again. :blush:


I’ve got the same issue.

I have already an account using GitHub.

First i clicked on the button ‘Start coding its free’ and signed in with my current email and a confirmation code. Having signed i cannot see my previews FCC work.

I tried then to SignIn with GitHub. I entered my email into the ‘Update your email address here:’ box. for verification. A message then appears saying that ’ is already associated with another account.

So, any other solution please?

1 Like

A post was merged into an existing topic: When I click Curriculum it wants me to sign in