Cant get past ‘no thanks’ to email when signing up

Trying to set up an account for my son, its a no go. Very first screen says “something is not quite right a report has been generated”. When i close the warning and attempt to update account settings, none of the buttons work properly or settings are saved. Any clue what the hang-up is?

Have you tried

  1. clear the browser cache

  2. restart your browser

  3. try incognito mode

  4. try a different browser

  5. restart your computer

That usually works for any issues for me.

Thanks, but looks like a problem on FCC’s end that they solved. Working fine today.

I’m not aware of any changes on fCC’s end, but I’m glad it’s working now!

Well it’s not working again. Is it an iPad problem perhaps? I need it to work from an iPad browser in this case. When I try to select a choice it won’t deselect the other and I end up with errors.

Is the software on the iPad up to date? What version is the browser?

Yes it’s the latest. As you can see from the screenshot, trying to push buttons doesn’t unselect others. Everything turns black and nothing saves.

I think it may have something to do with the “assistive touch” button. I disabled that and it seems to be working again.