Can't get Skycons working

Can't get Skycons working
0

#1

I’m banging my head trying to get Skycons working in this pen.

I’ve looked at other pens that use it 100 times as well as at the web documentation and cannot for the life of me fathom why I can’t get it working. Maybe I’m doing something really stupid but have just been looking at it for so long that I can’t see it. Can anybody help?

Thanks. :slight_smile:


#2

Looks like the minified version of the Skycons library you’ve included is broken (that can happen sometimes when minifying a script).

Once I updated your code pen with the following url everything worked as expected:
https://darkskyapp.github.io/skycons/skycons.js


#3

Meh. I was fighting with your code for ages. I only managed to get it working locally. All these https & http CDNs everywhere :confounded:


#4

Thank you! That was driving me nuts. :thumbsup:


#5

Should have asked: how did you manage to track down the source of the problem?


#6

Hi @drguildo I checked your code and it looked good, so I started thinking there might be a conflict between jQuery and Skycons. So I started removing jQuery, Skycons, then I noticed on the Skycons website they are including the unminified library, so decided to plug that in instead of the minified version provided by Codepen and all of the sudden it worked. I guess it was intuition.


#7

Could someone please tell me where this code is found in the documentation on Skycons?[quote=“vdineva, post:2, topic:60034”]
https://darkskyapp.github.io/skycons/skycons.js
[/quote]


#8

Maybe I can answer my own question, is it from the file name in gibHub?


#9

Still trying to figure this out. The url in gitHub is https://github.com/darkskyapp/skycons/blob/master/skycons.js so this still doesn’t solve the problem. Anyone know?


#10

Thank you. Had the same problem with the minified script at https://cdnjs.cloudflare.com/ajax/libs/skycons/1396634940/skycons.min.js.
Your link fixed that. :sunglasses: