Can't get started with the Node/NPM challenges

Tell us what’s happening:
Hi, I’m trying to complete the first step of the " Managing Packages with Npm - How to Use package.json, the Core of Any Node.js Project or npm Package". I updated the package.json on the repl.it site but it doesn’t work. I have forked the bootstrap-npm site and updated the package.json there but it always gives me a fail message of “package.json should have a valid “author” key”

I would rather use the forked github site instead of relying on the repl.it. Surely all the test is doing is reading the package.json from the public fork. See below for the site. Thanks for reading my issue.

Your code so far
See https://github.com/w0404884/boilerplate-npm/blob/gomix/package.json

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36.

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

Hello there,

The tests make a GET request to the link you give them. This means they require a live, full-stack hosted app to have the request processed.

When you use Repl.it, and click the RUN button, a live server is created, which serves your app.

This means two things:

  1. You need to have the app running, when you click Ive completed this challenge
  2. You need to submit the link to the app, and not the workspace/folder/file containing text. So, a link to a fork will not work

I hope this clarifies.

1 Like

Thanks @Sky020. I didn’t understand that was how it was testing everything. Also, it is confusing exactly which link to paste into the test. I.e. the repl.it link vs. the repl.co link.

Thanks for the quick response. FreeCodeCamp is the best!

1 Like