Can't use node or react in my 32-bit linux

I have an old computer and it was so slow using windows, so I decided to install linux on it but now I’m finding out that I can’t use node or react or webpack and a lot of tools because the last version of node is unavailable for 32-bit linux machines

I tried a lot of things but I don’t know what to do now, obviously I cannot afford a new computer so I’m stuck

I really wanted to try out node and react, I’ve been studying for a while now and I even had a lot of projects that I was planning to make:(

have you tried gitpod? it’s a cloud dev environment, there you should have no issues with installing node

1 Like

If you want to run node locally on a 32 bit machine, your only choice is to either find a pre-built somewhere other than the main sources, or build it from source yourself.

Otherwise I’d recommend the approach @ilenia mentioned, which is to use gitpod, or codesandbox, or, or glitch to build and run your application via cloud tools. This way you just need a web browser to get to these “online IDEs” and use them instead of trying to get stuff to run locally.

However its worth bringing up that a 32bit system isn’t supported by a lot because your bound to run into other issues due to a 32bit system’s limitations, such as limited RAM or CPU performance. So even if you did get things running locally, you might have other performance issues.

The above solutions offset most of the issues to a single application, your web browser, but even then a 32-bit web browser will also run into limitations sooner than later.

1 Like