Challenge not accepting solution link - Request Header Parser Microservice

Tell us what’s happening:

When I submit my solution it’s not accepted, all tests fail. It seems like my solution link isn’t even opened because there’s no console log for the page being accessed, which happens with the other challenges.

Your project link(s)

solution: boilerplate-project-headerparser-march2022 - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.74 Safari/537.36 Edg/99.0.1150.46

Challenge: Request Header Parser Microservice

Link to the challenge:

Open your browser console on the project submission page and then run the tests. You’ll see a bunch of CORS errors. Then look at your code and you’ll see that you have the correct CORS stuff after your whoami route.

Express configuration is order dependent.

Ah got it. I tried this and still didn’t work, but checking the console I saw some ERR_BLOCKED_BY_CLIENT entries. The network I’m on blocks some stuff, so I tried a different network and it passed. Thanks!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.