Check code button not working

i’ve been stuck on step 42 for a while since check button decided not to work on that same step , i have tried going to other browsers , thing is i have went and retried previous step and check button worked just fine but when i reach step 42 it just stuck not woring

please share your code and the link to the step. You probably have a syntax error, it would be visible in the console.

i dont have a syntax error or any kind of errors check button is not working i keep spamming it , doesnt give me errors or any help options or anything its just stuck

Please share your code

have you opened the console to look?

Create three new empty functions called buyHealth, buyWeapon, and goTown.

buyHealth{

}

buyWeapon{

}

goTown{

}

yes, that’s a syntax error.

What are you trying to do? What is the link to the step?

its asking for 3 empty functions

  1. Learn Basic JavaScript by Building a Role Playing Game
    step 42

and how do you define a function?

please , understand what im saying my problem is not with the code its with site itself not working , i click check code nothing happens litteraly , there i fixed code and same thing , ive also changed browsers , went to previous steps to test and check button worked but when i achieved step 42 check button got stuck again

buyHealth(){

}

buyWeapon(){

}

goTown(){

}

I tell you, you have three big syntax errors, they break the JavaScript in the page, including the JavaScript that makes the button work

You are missing a very important keyword in your code to create a function

Really ? can you tell me which keyword is missing

function is missing, look at the other functions in the code, how are they defined?

ohh , my bad thanks i completely forgot , i had no idea site can go down if i do such error

if the issue is a syntax error, it appears in the console, you should check it when the Check your code button doesn’t work

1 Like