Choropleth 1 County Missing

Hi everyone,

For some reason my choropleth is missing one county (id / fips = 5089) and I can’t figure out why for the life of me.

The array of length 3142 magically becomes 3141 when I pass it in the data and enter of the svg.selectAll(‘path’) part. Does anybody have an idea for the cause?

Link to pen:
https://codepen.io/dsobbo/pen/qBrXmmO

Thanks and have a good day

Well, you fixed it (or it fixed itself) before I could look. What was the solution?

I am curious because this had to be the best bug of the day. One little county, shunned in northern Arkansas because of its educational attainment. Definitely strange since everything else was working.

Oh yeah I fixed it haha. It was frustrating and I didn’t figure out what was causing it, but the county missing was in index 0 of a data variable = topojson.feature thing, so for the d3 data I just passed in .data([datavar[0], …datavar]). It’s a hack instead of a smooth fix but it works in the end

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.