Cloned Nodejs project showing errors on npm start

Logs Below

Logs
0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'start' ]
2 info using npm@6.14.10
3 info using node@v14.15.4
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle OhPhish@1.0.0~prestart: OhPhish@1.0.0
6 info lifecycle OhPhish@1.0.0~start: OhPhish@1.0.0
7 verbose lifecycle OhPhish@1.0.0~start: unsafe-perm in lifecycle true
8 verbose lifecycle OhPhish@1.0.0~start: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/sachin/Desktop/Projects/api.ohphish.com/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
9 verbose lifecycle OhPhish@1.0.0~start: CWD: /home/sachin/Desktop/Projects/api.ohphish.com
10 silly lifecycle OhPhish@1.0.0~start: Args: [
10 silly lifecycle   '-c',
10 silly lifecycle   'NODE_PATH=./app/libs:./config NODE_ENV=development node server.js'
10 silly lifecycle ]
11 silly lifecycle OhPhish@1.0.0~start: Returned: code: 1  signal: null
12 info lifecycle OhPhish@1.0.0~start: Failed to exec start script
13 verbose stack Error: OhPhish@1.0.0 start: `NODE_PATH=./app/libs:./config NODE_ENV=development node server.js`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
13 verbose stack     at EventEmitter.emit (events.js:315:20)
13 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack     at ChildProcess.emit (events.js:315:20)
13 verbose stack     at maybeClose (internal/child_process.js:1048:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:288:5)
14 verbose pkgid OhPhish@1.0.0
15 verbose cwd /home/sachin/Desktop/Projects/api.ohphish.com
16 verbose Linux 5.4.0-42-generic
17 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "start"
18 verbose node v14.15.4
19 verbose npm  v6.14.10
20 error code ELIFECYCLE
21 error errno 1
22 error OhPhish@1.0.0 start: `NODE_PATH=./app/libs:./config NODE_ENV=development node server.js`
22 error Exit status 1
23 error Failed at the OhPhish@1.0.0 start script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]


Did you run npm install ?

Yes. I have run npm install. Kindly suggest what am i missing ? My node version is 14.15.4

You should probably share the link to the repo.

I have deleted node modules folder and run the npm install command again get the output shown below… and I can’t share the repo link.

Try this: https://github.com/Automattic/node-canvas/issues/958#issuecomment-427618140

Logs
sachin@sachin-Inspiron-15-3567:~/Desktop/Projects/api.ohphish.com$ sudo apt-get install libcairo2-dev libjpeg-dev libpango1.0-dev libgif-dev build-essential g++
[sudo] password for sachin: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: gcc (>= 4:9.2) but it is not going to be installed
                   Depends: make
                   Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
 g++ : Depends: gcc (= 4:9.3.0-1ubuntu2) but it is not going to be installed
       Depends: g++-9 (>= 9.3.0-3~) but it is not going to be installed
       Depends: gcc-9 (>= 9.3.0-3~) but it is not going to be installed
 libcairo2-dev : Depends: libcairo-script-interpreter2 (= 1.16.0-4ubuntu1) but it is not going to be installed
                 Depends: libfontconfig1-dev (>= 2.2.95) but it is not going to be installed
                 Depends: libfreetype6-dev (>= 2.1.10) but it is not going to be installed
                 Depends: libx11-dev but it is not going to be installed
                 Depends: libxrender-dev (>= 0.6) but it is not going to be installed
                 Depends: libxext-dev but it is not going to be installed
                 Depends: libpng-dev but it is not going to be installed
                 Depends: libsm-dev but it is not going to be installed
                 Depends: libpixman-1-dev (>= 0.22.0) but it is not going to be installed
                 Depends: libxcb1-dev (>= 1.6) but it is not going to be installed
                 Depends: libxcb-render0-dev (>= 1.6) but it is not going to be installed
                 Depends: libxcb-shm0-dev but it is not going to be installed
                 Depends: libglib2.0-dev but it is not going to be installed
 libjpeg-dev : Depends: libjpeg8-dev but it is not going to be installed
 libpango1.0-dev : Depends: libfontconfig1-dev (>= 2.11.91) but it is not going to be installed
                   Depends: libfreetype6-dev (>= 2.1.7) but it is not going to be installed
                   Depends: libfribidi-dev (>= 0.19.7) but it is not going to be installed
                   Depends: libglib2.0-dev (>= 2.59.2) but it is not going to be installed
                   Depends: libharfbuzz-dev (>= 2.0.0) but it is not going to be installed
                   Depends: libthai-dev (>= 0.1.22-3~) but it is not going to be installed
                   Depends: libx11-dev (>= 2:1.3.3-2) but it is not going to be installed
                   Depends: libxft-dev (>= 2.1.14-2) but it is not going to be installed
                   Depends: libxrender-dev (>= 1:0.9.0.2-2) but it is not going to be installed
                   Depends: pango1.0-tools (= 1.44.7-2ubuntu4)
 mongodb-org : Depends: mongodb-org-server but it is not going to be installed
               Depends: mongodb-org-mongos but it is not going to be installed
 mongodb-org-tools : Depends: mongodb-database-tools but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Now this issue…

Hello there,

I have edited your posts for better formatting. It helps keep the forum more tidy, as well as makes reading and comprehending posts easier.

If you post a lot of text/code/logs please use backticks to encapsulate the text:

[details]
```
Text/code goes here...
```
[/details]

Thank you