Cloud9 is now AWS Cloud9 and I'm stuck

Given that Cloud9 is now part of Amazon’s AWS platform, the tutorial videos are outdated. I’ve managed to figure things out for the most part, but not with any level of confidence. Here are my questions:

Amazon has a few new options to choose from when creating a new environment that I don’t understand. I also selected the “free” tier upon signing up, but apparently they can still bill me. What options should I choose to get the challenges to work and also avoid getting billed?

AWS Cloud9 is constantly telling me to use an “IAM user” instead of the “root account”. Does this matter given that I’m only using AWS for these challenges?

I’ve managed to get through the “how-to-npm” and “learnyounode” challenges, but I keep getting “file not found” and “no such directory” errors when I try to install “expressworks” in AWS cloud9. I’ve tried the installation link provided on the challenge page and also tried just installing it normally. Nothing seems to work. Thoughts?

Should I just ditch AWS and run these challenges natively on my pc?

Thanks for the help!

You can do those challenges on your pc.

We’re also moving away from Cloud9 to But I don’t think glitch is ideal for the mentioned challenges.

1 Like

I managed to get through the expressworks tutorials by following the expressworks installation info on their github page (here:
Basically, in c9 just install expressworks globally and then it should run as needed, and you can get through those challenges.

I went through the IAM User setup on AWS, but it’s probably not worth the effort for JUST this – for me, I wanted to go through it just to learn a bit more about how AWS works, since it might(?) be useful later.

Now, saying all that, I’m stuck on the next part, which is learning MongoDB :frowning:
So I’m working on figuring out how to get it working in AWS/Cloud9.

As usual, if in doubt, read the docs:

So the problem that I was having was that when I tried installing mongo with the prepackaged Amazon install (sudo yum install mongo) - doesn’t (for some reason?) install everything that you need for learnyoumongo (specifically the mongo daemon mongod (I think?) so leanryoumongo wouldn’t continue.

So here’s a really tiny mini tutorial:

  1. open a new terminal
  2. go to the directory /etc/yum.repos.d/ (cd /etc/yum.repos.d)
  3. create a new file named “mongodb-org-3.6.repo” (sudo touch mongodb-org-3.6.repo)
  4. edit it and copy the repo information from the page (linked above) into the file (open it for editing with: sudo nano mongodb-org-3.6.repo)
  5. paste and exit nano (ctrl+x) (answer yes to save changes)
  6. You can close this terminal now, and go back to your environment terminal.
  7. Continue to follow the setup instructions here: - with the following change: instead of: $ echo 'mongod --bind_ip=$IP --dbpath=data --nojournal --rest "$@"' > mongod; do & echo mongod --bind_ip=$IP --dbpath=data --nojournal > mongod
  8. OK, so now when you run $ mongod from your directory there, it should start up the mongo server and you can pass the “mongod” challenge in the learnyoumongod tutorial.

Hope that helps someone!