Code is correct but it shows Error

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**

<html>
<body>
  <h1>CatPhotoApp</h1>
  <main>
    <h2>Cat Photos</h2>
    <!-- TODO: Add link to cat photos -->
    <p>Click here to view more 
      <a href="https://freecatphotoapp.com" target="_blank" src="https://freecatphotoapp.com">cat photos.</p>
    <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"></a>
  </main>
</body>
</html>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.67 Safari/537.36

Challenge: Step 14

Link to the challenge:

Hello there.

Do you have a question?

If so, please edit your post to include it in the Tell us what’s happening section.

Learning to describe problems is hard, but it is an important part of learning how to code.

Also, the more information you give us, the more likely we are to be able to help.


You have not wrapped the image element in a properly formed anchor element.

In hint this is shown " Your anchor ( a ) element should have a closing tag. Closing tags have a / just after the < character." but i already done this step but still it shows error

You don’t have an opening tag.

my anchor tag is already open nd then i also closed it

You need two anchor tags. You should not have made edits outside of the editable region provided.

but there will be only one anchor tag more than one anchor tag will show error

You currently don’t have more than one anchor tag.

You should not change any of the previous code you were given. You need to add a new anchor tag around the image element without changing the current anchor tag. That’s why the first anchor tag is outside of the editable area.

1 Like