Codepen adding domain to my links

I have searched around on this quite a bit and none of the solutions are working for me. I’m trying to get my tweet link to work in the random quote generator project. No matter what I do codepen is just appending my href to its base domain. Can anyone help?

maybe you need to write http in front of the url

doh…that fixed it thank you.

However now I’m getting this error…

add target="_blank" to the anchor element, see if that works

Already had that unfortunately it doesn’t seem to help.

I was basing on one of the advices on this thread:

the issue is given by a change in twitter

anyway, this shouldn’t stop you from passing the tests

Much appreciated.

I tested what another user in that thread said, it actually works if you right click the link and choose open in new tab.

I am using Brave browser for the record, I think it’s pretty much identical to chrome.

And yes the tests do pass, I guess that will suffice for now.

I’ve tried it myself, that’s why I added that comment at the end

1 Like