Codepen on mobile

Okay this is driving me batty. I have been using codepen on my phone and some of my code has not been working. I attributed it to me making mistakes in typing. Well, i started over. Made a simple unordered list in html, then in css set it to have no styling. Nothing happened.
I double checked to make sure I hadn’t typed it wrong. It was fine. Then i copied the css line from another page. It worked. So i commented it out and tried mine again. Nothing. Then when removing the comment i accidently deleted the } . So i typed it back. Suddenly their code wasn’t working.
I tried it in multiple browsers, with different keypads and it doesn’t work.

Now, if I copy my non working code into sololearn it still doesnt work, BUT if I delete the {} and retype them in that editor, magically it works. So for some reason, that i cannot comprehend, codepen mobile thinks my {} brackets are garbage.

Am i crazy?

You would need to give us a link to your code or post your code into a reply here so we could see what is going on. Also, you would need to explain exactly what is not working with your code that you expect it to do.