CodeRoad not loading in window

I’m working on learn-sql-by-building-a-student-database-part-2. Everytime I load it today, I get an error, whereby the CodeRoad window remains blank and en error message pops up bottom right. It reads:

“Error loading webview: Error: Could not register service workers: SecurityError: The operation is insecure”

Anybody else getting this? Is there a workaround I can try? I’ve tried loading straight in codeally and, whilst that worked yesterday (when I was experiencing above issue as well), today their playground is 404ing.

I’m not seeing this - are you still having problems @obarzanka? Everything looks like it loaded up for you there. I would try to close CodeRoad and open it back up manually. There’s instructions and a gif here - it may take a few tries. Let us know if that works.

hey, thanks for checking! I’m still getting the issue, ie I load coderoad and then nothing comes up. I’ve followed the instructions in the gif, but just coming up with the error as usual :frowning:

Were you ever able to get it working @obarzanka? If so, what did you do?

Hello! I wasn’t ever able to get it working. And annoyingly when I’ve gone through CodeAlly directly, my completed challenges don’t transfer over :pensive:

The error may be related to a Firefox setting. Are you using Firefox?

See related links:

Hi @obarzanka I solved the issue. The issue is based on a firefox cookie policy or restriction. In my case I’m usign Mozilla Firefox 101.0.1 Version for Windows 10. You must disable Cookie Tracking, select Custom settings under Enhacing tracking protection, and the unselect cookies. Let me know if this works for you, for me takes 1.5 hours of investigation. (Firefox issue explanation: 1725216 - github.dev triggers "Error loading webview: Error: Could not register service workers: SecurityError: The operation is insecure.." if you have tracking protection configured to block cross-site cookies (the default in Nightly)), Next you can see the options in Firefox:

PD: And happened to me again. I just Only enabled and disabled the “Coookies” Box then I reloaded all the tabs and Works Again

4 Likes

I could cry! Maybe an overreaction but it works! Thank you so much for doing such a deep dive. Really appreciate it :pray:

1 Like

And happened to me again. I just Only enabled and disabled the “Coookies” Box then I reloaded all the tabs and Works Again