[COLLATION] Unable to move onto the next challenge

This is a thread for users who have experienced an issue with moving onto the next lesson even though they were able to pass the challenge.

The freeCodeCamp staff is aware of the issue and working on resolving it.

If you are having issues with submitting challenges using your default browser, then try using another browser to see if that temporarily solves the issue.


Please answer these questions to help us debug:

  • Challenge(s) affected
  • Your user agent
  • Your OS (operating system)

Thanks!

I can’t move on on the Basic Data Structures section of the course at Remove Items from an Array with pop() and shift(). When I pass the test, I click the Submit and go to next challenge button doesn’t do anything and doesn’t work. Sometimes I type on the code section and the debugger at the bottom freezes and is stuck on an error. No buttons work. I can’t progress. I s something wrong with this page on the site?

Hello there,

I can see no issue with the site in reference to that, or the next, challenge.

Some things to try:

  • Hard-refresh the page
  • Ensure no browser extensions have access to freecodecamp.org

Hope this helps

Well, I restarted the Chrome browser, disabled extensions, even reset the computer, but still the same thing. However, I switched to a different browser (Opera) and it worked !
Then I switched back to Chrome, and the rest of the tests are working fine.

1 Like

Hey all,
I’m doing the Basic JavaScript course and have made it to assignment 55: Assignment with a returned value. After typing the solution into the script editor the console below gave a syntax error. This confused me as I tested the answer on a separate blank window I created which said the solution was correct. I then copied the solution, reset the assignment and pasted the solution into the editor. The syntax error did not appear so I pressed Run the Test which said I had passed. Great! However, When I press to move to the next assignment, nothing happens. I have tried this with previous assignments that I have already completed and they are all doing the same thing. Is anyone else having the same issue?

Please show the code you are trying and a link to the challenge. In the future, if you use the Get Help -> Ask for Help button, it will do that for you.

I am not having trouble with the code. The code not the issue. The issue is with the website not letting me move onto the next assignment. There seems to be a communication issue between the site and my profile.

HI @ryanSyder !

Welcome to the forum!

It sounds you are going through the same situation as this user

They were able to resolve it by using another browser.

Hope that helps!

Forgive me, but if I had a dollar for every time someone said that…

But hopefully you’re right and Jessica’s advice fixes it.

Amazing! Thank you, I will give that a try.

Issue fixed. I switched from Chrome to Safari which has sorted the problem. Thank you very much for your help.

I’m having this same issue for the Javascript “Use the parseInt Function with a Radix” lesson. The solution is marked correct, but nothing when happens when I click “Submit and go to the next challenge.” I’ll switch browsers for now to see if that helps. But hopefully the issue can be fixed for Chrome users.

On the ‘Basic JavaScript’ course, I seem to be unable to submit and move on to the next challenge. The tests pass and I get the popup window, but the button nor (ctrl + Enter) work.

The lesson I’m stuck on is
‘Explore Differences between var and let keywords’

Any help is appreciated ty!!!

I am also having the same issue. I am at JavaScript Algorithms and Data Structures Lesson Reset an Inherited Constructor Property

1 Like

Same problem here, they knew about this, hope will fix soon

1 Like

HI @staplerg and @JustJasmine !

Welcome to the forum!

I moved your posts over to this thread.

The staff is aware of the issue and working on a fix.
For now, try to use another browser and see if that temporarily resolves the issue.

Thanks!

2 Likes

Accepted the challenge from Edge, use it as temporary fix

After completing the work in javascript, somehow it’s not letting me to move on to the next lesson. It even shows the completed screen, but when I click on “move to next lesson”, nothing happens. ctrl +enter doesn’t work either. I tried all the extensions that I have on my chrome and nothing. I even tried delete the chrome and re-install. Please help.

Hi @mturtle051 !

Welcome to the forum!

I moved your post over to this thread with the other users experiencing the same issue.

Please read through the top post and provide answers to those threes questions.
That will help the staff identify the issue.

For now, users have had luck using another browser.

For the past few hours, a few of my friends and I haven’t been able to press the ‘Submit and go to next challenge’ button in the JavaScript curriculum. I was wondering if anyone else was encountering the same issue?