Comment out <p> element

****Tell us what’s happening:
Am asked to uncomment the h1 and p element leaving out only the h2 which i did but I keep on getting an error that I should still uncomment my p element

Your code so far


<h1>Hello World</h1>
<p>Kitty ipsum dolor sit amet, shed everywhere shed everywhere stretching attack your ankles chase the red dot, hairball run catnip eat the grass sniff.</p>
- —>

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.


1 Like

Thing 1: You still have comment tags around your paragraph element.

Thing 2: The second dash in all your comment tags is not a normal dash. My best guess is that you are using an Apple device. Apple changes a number of characters automatically as you type. I believe that the setting that you have to turn off is called something like “smart punctuation”.

really? I use MacBook Pro and I have the same problem.

That’s an Apple device.

The “smart quotes and dashes” setting is only enabled on macOS for rich text areas, like what you get with TextEdit. My MacBook has it enabled, and I’ve never been bitten by it when writing code. Then again, I don’t use TextEdit to enter code.