Cookies are enabled but website says they're not

I am trying to use node with Puppeteer to log in to a website but it doesn’t let me navigate to the login page. Instead I am re-directed to a page that says that I need to enable cookies in my Chromium browser. When I navigate to the login page manually, I’m not re-directed and my cookies are enabled so I don’t know how to fix this.

Without seeing your code or knowing what site you are trying to login to it is pretty hard to help.

Does it work if you set headless to false and make sure you have enough of a delay on the actions?

I wrote to the web site owner and told them that I can’t get to the login page. They told me to clear my cache and re-start my browser. I did that but it still doesn’t work.

Here is my code:

const puppeteer = require('puppeteer');

(async () => {
  const browser = await puppeteer.launch({
      headless: false
  const page = await browser.newPage();
  await page.goto('');

  await page.waitFor(500);

I tried using zombie instead of puppeteer but I couldn’t get it to open the browser at all.

Please PM me the web site link.

You don’t seem to be getting the cookie/s at all, plus you need to save them somewhere so that on second run Puppeteer can use them to log in. The code you’ve posted has neither of these things. Puppeteer (like any headless browser) has specific APIs for doing this, it isn’t automatic.

lasjorg solved the problem by sending me a new login URL.