Couldn't import polygon-area-calculator repository from Github

Hi *
I’m currently doing the scientific computing with python course
from the freeCodeCamp’s curriculum, so far i have completed
the first three out of 5 projects(challenges) given.
I did this as prescribed in the challenge by importing the corresponding
repository from GitHub and working on it until finished(passing the tests)
and submitting them, everything worked fine.

Before 2 to 3 days then i wanted to start working on the PolygonAreaCalculator project.

So i followed the link in the projects description to import the
repository <freeCodeCamp/boilerplate-polygon-area-calculator>
into replit but the import didn’t work i tried this again several times
but till now it doesn’t work it gives me this message below in the screenshot

Anyone who can help or had the same problem and solved it or knows
the cause of this problem ?
I know that this might have to do rather with the Replit plattform than with freeCodeCamp or GitHub but i wanted to ask first here hoping
that someone here knows about this issue

Thanks

The import works for me.

But you do have to configure the Run Command manually (and likely the dependencies…didn’t test it).

Try connecting your GitHub to your Replit. That sometimes helps with failed imports.

Thanks for taking your time and answering the question.
The situation is that my Replit is connected to GitHub i did succesfully
import the repositories for the previous projects arithmetic-formatter,
time-calculator and budget did configure Run for each project wrote
the code and succesfully completed the test run and submitted them.

But with polygon-area-calculator i now face this issue for the first time
i have no clue what is going on.

So i decided now to clone the repository directly
from GitHub to my home device which worked fine and manually upload
the necessary files to an empty new Replit.

Nevertheless i would be interested to find out the reason for this problem

Can’t really answer that, maybe it is just some intermittent issue. Did you try it again?

I assume if you just fork the repo and use your fork for the Replit import it works as well?


I guess it doesn’t really matter as long as you got it working.

Possible that my GitHub connection is not stable .
However i tried again and checked the connected services in my
account’s controll panel and it says i’m connected.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.