Course not showing the window with the course instructions

So I was starting to do the course from scratch and whenever I got to the first ls -1 command, I couldn’t move forward, it said something about the test must pass, I read all the hints and it was very clear to me that I had to write ls -1 as the next code. So whenever I tried to refresh my screen to see if there was an error, I was back at freeCodeCamp where I click “Click here to start the course” and then “Run in CodeAlly”. I did both and the next thing I saw was the assistance for continuing with the course was gone, only the terminal and the “getting started” page are there, and I don’t know how to reset it or bring that window back up. It’s frustrating first because the ls -1 code was not going through and then because there is no easy way I could find to open again the helper.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.60 Safari/537.36

Challenge: Build a Boilerplate

Link to the challenge:

Welcome there,

Just to mention: The command is not ls -1. You are expected to use ls -l That is, there are no numbers in the command, the flag is a lowercase l (el).

Hope this helps

hmm I never saw that as a lower “L”, but I will try.
Now, what about the course window not showing? I can’t literally go back to where I was

I am not entirely sure what you are seeing.

In my experience, after starting a course (provided you have not logged out from freeCodeCamp), you should just be able to re-open the course. Then, once the VM has re-started, you can start CodeRoad, and open up the menu to select the latest-passed lesson.


This is what I see, I don’t know how to re-open the course, I don’t see any option to do that

So, you can re-open/start CodeRoad, by opening the command palette, and selecting the command CodeRoad: Start

1 Like

Did you get this resolved @Casio04? There’s a gif showing what @Sky020 described here that may help.

Hi, I haven’t been able to try this because I just went out on a trip and I don’t have my laptop to test this. Will be able to do so in one week.

Thank you for the replies.

I was just able to restart the guide. Now I wrote ls -l and it still won’t let me go through

I would try using that reset button to get back to the start of that step @Casio04 - maybe something got a little messed up in this process. Let us know if that works.

Yeah I did that twice, restarted the guide and signed out-signed back in and nothing worked.

I’m not quite sure what you mean by “restarted the guide” - you restarted CodeRoad I’m guessing.

There’s a bug I’ve been trying to fix where the tests get a little messed up from time to time. If that’s the issue, there’s a way around it, but it’s tough to explain and is probably more of a pain than just starting at the beginning again. There’s instructions how to start over here. You’re not that far into the tutorial, you should be able to catch back up in a few minutes. Here’s some motivation if you’re feeling frustrated. Keep in mind that these are in a beta stage, and the bugs are still being worked out.

You may notice that you can’t see the instructions displayed on the screen during an exam because they are covering the video area. To fix this, click on the green bar at the bottom of the course window. This will open a setting where you can adjust the position and size of the display to fit your needs for your course.