Create a Form Element1

Create a Form Element1
0.0 0

#1

Tell us what’s happening:

Your code so far

<link href="https://fonts.googleapis.com/css?family=Lobster" rel="stylesheet" type="text/css">
<style>
  .red-text {
    color: red;
  }

  h2 {
    font-family: Lobster, Monospace;
  }

  p {
    font-size: 16px;
    font-family: Monospace;
  }

  .thick-green-border {
    border-color: green;
    border-width: 10px;
    border-style: solid;
    border-radius: 50%;
  }

  .smaller-image {
    width: 100px;
  }
</style>

<h2 class="red-text">CatPhotoApp</h2>

<p>Click here for <a href="#">cat photos</a>.</p>

<a href="#"><img class="smaller-image thick-green-border" alt="A cute orange cat lying on its back. " src="https://bit.ly/fcc-relaxing-cat"></a>

<p>Things cats love:</p>
<ul>
  <li>cat nip</li>
  <li>laser pointers</li>
  <li>lasagna</li>
</ul>
<p>Top 3 things cats hate:</p>
<ol>
  <li>flea treatment</li>
  <li>thunder</li>
  <li>other cats</li>
</ol>
<input type="text" placeholder="cat photo URL">

Your browser information:

Your Browser User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36.

Link to the challenge:


#2

Hi Anas
What exactly is going wrong here?

I remember that in this stage you’re supposed to add a <form> tage with the appropriate attributes as the instructions say before your <input> element and close the </form> after it.


#3

‘’[quote=“AyahSalha, post:3, topic:190162, full:true”]
‘’

'' [/quote] Why the code i post in replay does not appear ?? ` `

#4

You’ll need
then you put
and then closing
Note: Instead of POST you could use GET method. This method is used when url needs to bookmarked for example.
If you’re not sure which method to use, read about POST and GET methods for forms. Also action attribute is used to “send” data gathered by submitting to specific php files who handles them. In this case, you should leave it blank like this: action="" since you don’t need to sen data anywhere … PS: inside a form include button with attribute submit: <button type="submit> Click me to submit data


#5

@AyahSalha
When you write code in the Reply,
after writing it… select it and hit the icon that looks like this
</>
in the toolbar of the reply editor…

orrrrrr… select the code and press
ctrl+shift+c