Create and Save a Record of a Model challenge on FCC backend

I have completed the challenge and my person actually gets saved on atlas but for some reason my tests fail i have changed db names and collection names to try and figure out anything that can point me to the problem but to no avail can anyone assist

Your project link(s)

solution: https://replit.com/@victorkwasara/boilerplate-mongomongoose-3

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36

Challenge: Create and Save a Record of a Model

Link to the challenge:

You should stick to the package versions shown in the first challenge. Your mongoose version is different.

I didn’t test your code, but I didn’t really see anything immediately wrong.

Edit: I just ran your code and it is passing for me. But still, I would suggest you always keep the package versions in sync with what is asked for in the challenge. Otherwise, you may run into breaking changes between versions that can cause the tests to fail.

On replit i tried to search for packages on the packages tab and only specific versions where showing, i then updated the package .json file soo that it installs the versions that is required by the question but after running the app when i checked the installed packages tab it had different packages from the one in my package json and also i got this error the options [useUnifiedTopology] is not supported . I then just tried installing the packages available on replit without specifying in package .json thats how i managed to get throught the first challenge

Perhaps you have quotes around the secret environment variable:
{ "MONGO_URI": "'[...]'" }. It should be { "MONGO_URI": "[...]" }.