Curriculum Not Loading (blank page only)

Whenever I click “go to curriculum”, it loads a blank page. After reading other confused users’ posts, I tried clicking “curriculum” at the top right corner instead and it worked! However, when I tried going to my very first actual lesson, the same issue occurred. It loaded to a blank page. What can I do to make this work on my OS?! Please help!!!

I have a Mac OS X version 10.8.5

No issues with your OS version, I am on Mac OS X and works fine.
Maybe try clearing the cache.

Can you explain how to clear the cache? I’ve been using computers for a long time, but never really learned the nitty gritty

If you are on chrome,

  1. On your computer, open Chrome.
  2. At the top right, click More More.
  3. Click More tools > Clear browsing data .
  4. At the top, choose a time range. To delete everything, select All time .
  5. Next to “Cookies and other site data” and “Cached images and files,” check the boxes.
  6. Click Clear data .

I tried it, cleared all browsing data from beginning of time and still has the same issue. I really appreciate your help, by the way. Is there anything else I can try?

What browser are you using? Have you tried using Chrome?

Can you try using another browser? Maybe firefox?

If you hit F12 when you try to go to the curriculum page, do you see any red error messages? Are you using a VPN or are you on a managed network (work, school, library, etc)?

Currently, I am using Chrome.

I’m using a VPN.

Your VPN is probably blocking FCC. We’ve seen this happen before where some VPNs that people use prevent them from accessing our curriculum.

not sure which one to show you

Thank you for your help and your time. How can I fix this issue?

Don’t use that VPN when you are trying to use FCC.

Wait, actually I looked up what a VPN is again and I don’t think I have a VPN. I’m just using my macbook at home with our regular internet and wifi and my personal computer. Sorry but I’m still very noob at this.

Do you have any browser extensions added in Chrome?

I have the extension Honey which automatically applies discount codes or coupons to purchases during check out. I disabled it and tried refreshing my curriculum again and that didn’t work either.

What version of Chrome are you using? Have you tried accessing the site from another browser?

I tried it on safari but I already knew it wouldn’t work on there. Do you have a recommended browser? According to other users, Firefox may work.

Google Chrome is the recommended version. That’s why I’ve been asking about your personal configurations: because Chrome itself works well with FCC. It looks like your version is extremely out of date. You are on Chrome version 49, and the current version is 73. I wouldn’t expect that to completely prevent a page from showing up (especially without more obvious browser errors) but that is possible. Similarly, although Safari does not work well with the tests that FCC runs to verify solutions, it does normally at least bring up the curriculum fine.

Is there a reason why you haven’t updated your operating system in so long? It looks like you are on 10.6, 10.7, or 10.8 (so 7 or more years and 6 or more versions out of date).