D3 TypeError: TypeError: Cannot read property 'presets' of undefined

Tell us what’s happening:

Hey, this is the issue with multiple problems I’ve tried to solve, trying to see what’s the fix. Thanks for the help in advance!

Your code so far


<body>
 <ul>
   <li>Example</li>
   <li>Example</li>
   <li>Example</li>
 </ul>
 <script>
   // Add your code below this line
d3.selectAll("li").text("list item")
   // Add your code above this line
 </script>
</body>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36.

Challenge: Select a Group of Elements with D3

Link to the challenge:

Working fine for me. What is the issue again?

Every time I enter the code and I know its right after I checked the solution. I get the same message TypeError: Cannot read property ‘presets’ of undefined. Any suggestions?

Where do you see that error? Does that error stops you from validating the challenge and going further?

Try to clear site data, refresh the page?
Log out log back in ?
Use a different browser?

1 Like

Worked out. Thanks for your help man!

1 Like

and yes it was stopping me from validating the challenge on multiple problems and i wasn’t sure if i had just entered something and missed it.