Data Analysis with Python - broken Notebook?

I can see the .ipynb files in the provided GitHub link and have downloaded these to my local machine. (Just opening them gives a pdf ‘dead’ version).
I’ve installed Anaconda and have Jupyter Notebooks running locally.
Notebooks gives the error that the provided files are not JSON.
Is there a trick to using these notebooks that are integral to the course?
Do I need a specific antique version of Notebooks - I see Anaconda lets me regress versions of tools to support this.
Or is this course dead?
Disappointing compared to Chuck’s amazingly slick Scientific Computing course.

can you please provide a link to the page where the notebooks are linked?

1 Like

Most of the lessons in the course have a ‘Notebooks on GitHub’ link, for example:

have you tried with google colab?

Haven’t tried Colab - the instructions appeared to be to install Anaconda and a ‘local’ version of Jupyter Notebooks so did that.
As course files were committed 2 years ago I assumed they were out-of-date compared to current version of Jupyter Notebooks and was hoping for a simple reversion in Anaconda back to a version that ‘just worked’.
Or perhaps someone here knowing a tool to ‘update’ or load old notebook files so I can then save myself in current version.
The ‘clues’ seem to indicate Colab is more complex so had not tried. I’ll go see if that works any better - this playing is more fun than work! <3

Yes, by taking the GitHub link, hand-crafting URLs for each link following the instructions it is possible to open each notebooks in Colab. Functionality is kinda then like the course material. Obviously all of the course material explaining how Jupyter Notebook works, well, doesn’t…

Perhaps worth a note at the top of the course that this workaround is available for those who really want to fight on throught?

And I haven’t tried to see if I’ve got all the expected libraries yet.

So in Colab:

Hmmm… The ‘exercises’ sheet is giving both question and answer whenever a question is opened.

And I’m getting ‘depricated feature’ warning messages for the types used.

I think the course is toasted… If the exercises struggle, not sure it’s worth pushing to the coursework and expecting that to work/give credit.

the Google Colab instructions were added to the website because Jupyter wasn’t working

have you created your own copy of the notebook?

I saved the GitHub files to a local drive but Anaconda/current version of Jupyter Notebook says something about they’re not JSON.

In Colab I fuddled the link to open the GitHub files in Colab as per instructions but the result seems less than optimal as the exercise and answers open as a pair.

Ok - looks like it was my failure to drive GitHub.
Simply saving the files does NOT give the a copy of the committed file.
Apparently it is necessary to click on a file, click on ‘RAW’ and then ‘save as’.
That file is then opening and working in Anaconda/Notebook current releases.

I am very familiar with version control systems but haven’t seen one work like that before - normally the returned file is a copy of the committed file - that’s the point.
Attempting course again…