Data Analysis with Python Projects - Mean-Variance-Standard Deviation Calculator

Tell us what’s happening:

Describe your issue in detail here.

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/121.0.0.0 Safari/537.36

Challenge Information:

Data Analysis with Python Projects - Mean-Variance-Standard Deviation Calculator

GETTING ERROR WHILE RUNNING FILE NUMPY 1.18.5 DOES NOT SUPPORT PEP517 BACKEND ERROR

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.

while running the main.py i am getting backend error that Numpy 1.18.5 doesnt support pep517 wheel

https://forum.freecodecamp.org/t/data-analysis-with-python-projects-mean-variance-standard-deviation-calculator/668990/3?u=malvika

Can you post a link to your replit?

You can try deleting pyproject.toml (may need to show hidden files)

Hello,
Thank you for response its not getting deleted.
Attaching link: boilerplate-mean-variance-standard-deviation-calculator (1) - Replit

What do you mean? Do you get an error when you try to delete that file?

I’ve forked your project, deleted pyproject.toml

I also had to install numpy by typing pip install numpy at the Shell command prompt.

It ran and passed the tests :+1:

1 Like

Thank you so much :slight_smile:

Try to do the same thing and let me know if it works?