Delete Many Documents with model.remove() error updates

Tell us what’s happening:
Cant complete and I can’t understand why I tried changing versions also tried using deleteMany also tried recreating the cluster

Your project link(s)

solution: boilerplate-mongomongoose - Replit


const removeManyPeople = (done) => {
  const nameToRemove = "Mary";
	Person.remove( {name:nameToRemove},(err,data)=>{
		if(err){
			console.log(err);
		}else{
			done(null,data);
		}
	})
  
};

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.0.0 Safari/537.36

Link to the challenge:

Try installing the versions of the packages asked for in the initial challenge.

You have the closing parentheses in the wrong place here.

mongoose.connect(MONGO), { useNewUrlParser: true, useUnifiedTopology: true };

oh let me check ,thaks for the help

no cant complete maybe because I am thinking for too long will try later or tomorrow , i spent way too much time on this maybe change the checking code on git so other people dont face the same problem and use deleteMany or deleteOne

I’m getting a connection error (querySrv ENOTFOUND) for the DB but I’m not sure if its just caused by my IP not being white listed.

Not sure i understand how you passed the other challenges before this one with the syntax error you have for mongoose.connect

The syntax should be

mongoose.connect(connectionString, options)

As long as you use the correct version of the libs the remove method should work.

I changed the id and password for connection after i posted my relp here also i made it hidden thats the reason u cant connect, use user id and password belazy167 and try again also the cluster name is fcc