Does Twitch actually work?

Does Twitch actually work?
0.0 0

#1

I am about to start on the Twitch TV project, but I can’t find a working example. None of the Codepen projects seem to work. Or, rather, the Codepen projects work, but when I click the link, button, or whatever to display the actual Twitch stream nothing seams to work. I get the sidebar along the left and a large open white space that I assume should be displaying the stream, but all it contained was the little ‘please wait’ circle.

Since there are buttons for signing up and logging in I thought that maybe I need to have an account to see anything. So I clicked the ‘Sign Up’ button. The whole screen goes gray. You can see that the sidebar is there behind the gray, and the ‘Please wait’ thingy, and there is an ‘X’ in the top center. Clicking that ‘X’ will get me back to the previous state (without the gray) but nothing else ever happens. So I can’t sign up, or log on. I can’t see any streams. I can’t really do anything.

How is this supposed to work?

I don’t really want to spend time trying to create a viewer for something that does not work. It’s not my code that isn’t working, because I have not started to code this. It is every Codepen of the Twitch viewer that I have looked at so far (four or five of them, at least).

Can anyone shen some light on this?

Marc


What’s the deal with the Twitch.tv challenge?
#2

That happens to me in Chrome sometimes. Try it in different browsers to see if the browser settings are the source of the problem.

The answer to your question is yes, Twitch does work and you don’t need to log in to view the content.


#3

It works (shameless self-plug).

The problem is with Twitch not loading if the page is linked from iFrame.

Here is a GitHub issue

You can develop in codepen (or locally) and host on GitHub Pages


#4

Hi marcnshapiro, we just invoke the Twitch API to get the information format by json, not need to log in.

it can not working seems you browser or network issue. u can try in other browser or just send the “Get request” using this url: https://api.twitch.tv/kraken/streams/freecodecamp to see what happened.


#5

Well, still no luck. I started out using Firefox. I have since tried Chrome, Opera and QupZilla. Chrome and Opera behaved exactly like Firefox. QupZilla at least displayed something other than the sidebar. I got a display area with a ‘Play’ button and advertisements or other stream links below. When I clicked the “Play” button, however, the browser crashed. I tried two more times. No crash, but no streaming, either. The video display area went flat gray and the sidebar went totally black.

This is with the link displayed in step 1 on the project page.


#6

I found a link from someone asking for feedback that works for me after allowing Flash (on Firefox):

http://davidalley.net/projects/twitch/

So the first thing that I did was to update my Flash to the latest version for Linux. Still no luck on other sites.

As you can see, however, this one is NOT hosted on Codepen. It works on Firefox once I say to allow Flash, and it works on Chrome with no questions. I did not see a need to try Opera, or QupZilla. Is Codepen causing the problem? The last time that Codepen was causing me problems I solved it by accessing Codepen with http instead of https. Is there a way around this one, too?

Codepen may be convenient, but if it doesn’t work with FCC projects then maybe they should suggest another way to do them that does not have these problems. Can anyone suggest another site like Codepen that would not have these issues?

Marc


#7

How do you host it on GitHub? I was thinking that might be the answer, but I’m not at all sure how to set it up. I have a GitHub account, as it was set up as part of starting to work with FCC, buit I have not used it. I was thinking of putting all of my projects there, but I have not yet figured out how to do that.

Marc


#8

with this https://pages.github.com/


#9

#10

Thanks!

I have one page up and am in the process of debugging it. It works fine on CodePen, but not on Github. I will post a new thread with my questions on that problem. Once I get it working I will copy over the other pages and write the Twitch app there from the start.

Marc


#11

I was able to do the project by NOT using codepen, but rather Cloud9. I don’t know if links to Cloud9 projects persist forever, but at least for today - Oct 18 2016 - it does:

https://preview.c9users.io/bhboruff/fcc_twitch_project/index.html?_c9_id=livepreview1&_c9_host=https://ide.c9.io