As used in the FCC codebase, the curriculum helper class is instantiated as:
const helper = new __helpers.CSSHelp(document);
I thought at first the double underscore is for naming convention, but other instances of this helpers class from https://github.com/freeCodeCamp/freeCodeCamp/blob/266f789b0c1948611a7d06f4536d86a5afe2a70b/curriculum/challenges/english/01-responsive-web-design/css-grid/add-columns-with-grid-template-columns.md is also:
assert(new __helpers.CSSHelp(document).getStyle('.container')?.gridTemplateColumns === '100px 100px 100px');
I think this curriculum-helper class originates from here but in its README.md there’s no double underscores being used: https://github.com/freeCodeCamp/curriculum-helpers/blob/main/lib/index.ts#L102
Why do we need a double underscore when instantiating this helper object? Also, I saw there were some other helper or helpers files inside the freecodecamp repo, then how is the double underscore able to refer to the correct class?
Any insight or guidance is much appreciated!
Thanks!!