Efficient use of itertools in python

We have an array a of size n, and wants to select exactly x elements from it, such that their sum is odd. These elements do not have to be consecutive. The elements of the array are not guaranteed to be distinct.

Input

The first line of the input contains a single integer t(1≤t≤100)— the number of test cases. The description of the test cases follows.The first line of each test case contains two integers n and x (1≤x≤n≤1000)— the length of the array and the number of elements you need to choose.
The next line of each test case contains n
integers a1,a2,…,an (1≤ai≤1000) — elements of the array.

Output

For each test case, print “Yes” or “No” depending on whether it is possible to choose x elements such that their sum is odd.You may print every letter in any case you want.

sample input:

5
1 1
999
1 1
1000
2 1
51 50
2 2
51 50
3 3
101 102 103

sample output:

Yes
No
Yes
Yes
No

my code:



    from itertools import combinations
    def toto(x,li):
        c = 0
        a = combinations(li, x)
        a = list(a)
        for i in a:
            if sum(i) % 2 != 0:
                c = c + 1
                break
        if c > 0:
            print("Yes")
        else:
            print("No")
     
    nn = int(input())
    for _ in range(nn):
        n,x = map(int,input().split())
        li = list(map(int,input().split()))
        toto(x,li)

How can i make my code more efficient ?

Hier a try!
Call the function toto()

And Enter:
5
1 1
999
1 1
1000
2 1
51 50
2 2
51 50
3 3
101 102 103

And check the output!
For the moment I did not take optimization into consideration but I think we are on the right way.
I hope that is a little help!

from itertools import combinations

def toto():
    count = 0
    result = []

    print("Enter inputs as shown in the input of the task: ")

    tests = int(input())
    
    while (count < tests):
        n,x = map(int,input().split())
        el = map(int,input().split())
        combi = list(combinations(list(el), x))
        res = [x for x in combi if sum(x) % 2 != 0]
    
        if len(res) == 0:
            result.append("No")                
        else:
            result.append("Yes")

        count += 1
        
    print("\nOutput:\n")
    for item in result:
        print(item)

1 Like

Thank you so much, rielka :smiling_face_with_three_hearts:
Is there any other way to solve this without using itertools that run more faster than this?

Hier a try without “itertools.combinations(…)”.
Of course you also can define your own function (hier called “combination”) or use loops to generate the combinations needed.
Sometimes it is useful to use that so called memoization to speed up your code or use the “functools.lru_cache” that should be imported.

Normally are itertools efficient.

#from functools import lru_cache

def toto():
    count = 0
    result = []

    print("Enter inputs as shown in the input of the task: ")
    tests = int(input())
    
    while (count < tests):
        n,x = map(int,input().split())
        el = map(int,input().split())
        combi = list(combination(list(el), x))
        res = [x for x in combi if sum(x) % 2 != 0]
                   
        if len(res) == 0:
            result.append("No")
        else:
            result.append("Yes")
            
            
        count += 1 
    
    for x in result:
        print(x)

#@lru_cache(maxsize=32)
        
def combination(iterable, m):
    if m > 0:
        for i in range(m - 1, len(iterable)):
            for t in combination(iterable[:i], m - 1):
                yield t + (iterable[i],)
    else:
        yield tuple()
1 Like